Hiya, you need flash 10.

As of right now FP10 is in beta, you can get it here -> Get Adobe Flash player